Problem with images

If you want to report a bug.
arv
Posts: 3
Joined: 05.10.2006 12:24

Problem with images

Postby arv » 05.10.2006 12:45

I am using Blogdesk for writing to my Wordpress blog . Till now it works really good . But I am having problems wih images . While composing I cannot insert images at all . I click on choose file , select the image , ok and I come back to the blog with no reference whatsoever to the image eith in the normal view or the sorce view . The only way I can insert an image is by using external link but then the path that is hardcoded is d:\xyz\xyz.jpg so even after uploading it is looking for the file at the previous path . And there is no way I can use the image editor . Can anyone help me out here ?
I am on XP .

Johannes
BlogDesk
Posts: 553
Joined: 19.08.2005 20:29

Postby Johannes » 05.10.2006 18:15

Ok, try the following:

1) Open Start/Execute
2) Enter the following line (use copy & paste)

regsvr32 [Blogdesk-Path]\graphicsmill20.dll

where [Blogdesk-Path] is your complete BlogDesk path, i.e.

regsvr32 c:\program files\blogdesk\graphicsmill20.dll

and then press OK. If there is no error message, everything is fine.

3) Do the same thing with the following 2 lines:

regsvr32 [Blogdesk-Path]\graphicsmill20controls.ocx
regsvr32 [Blogdesk-Path]\graphicsmill20dialogs.dll

arv
Posts: 3
Joined: 05.10.2006 12:24

Postby arv » 05.10.2006 22:15

Thanks for the tip . I don't have the offending machine at the moment , will try it tomorrow . Something tells me it will work :-)
I installed blogdesk at my home computer as well and the images tool works like a charm . Great stuff .

arv
Posts: 3
Joined: 05.10.2006 12:24

Postby arv » 15.10.2006 14:40

Johannes , I am sorry to inform you that the fix did not work . Registered all the thee strings with no errors but didn't work . Any ideas ?

kuntau
Posts: 10
Joined: 07.05.2007 23:25

Postby kuntau » 14.05.2007 21:32

+1

sorry to inform that also didn't work for me :(

wullar
Posts: 4
Joined: 03.06.2007 08:00

Postby wullar » 03.06.2007 12:33

I also can insert picture using External Link and not Choose File... as should be the case. After inserting the picture, the Picture Editor does not open and even after right clicking the picture and clicking Edit Image command nothing happens.

I used the RUN function to run the above commands (is that what had to be done)? and got the following error

Image


I am using Vista and Wordpress.com

Between a Justify option in editing would be a great add on.[/code]
Last edited by wullar on 03.06.2007 12:41, edited 2 times in total.

Johannes
BlogDesk
Posts: 553
Joined: 19.08.2005 20:29

Postby Johannes » 03.06.2007 12:39

Maybe it works better if you use quotation marks after the regsvr32 command. The above example would then look like this:

regsvr32 "c:\program files\blogdesk\graphicsmill20.dll"

wullar
Posts: 4
Joined: 03.06.2007 08:00

Postby wullar » 03.06.2007 12:47

Thank you for a quick reply. I did that and the error I got is:

Image

Any solutions?

I really love BD, it has increased my blogging frequency and the picture editor is just perfect, I do not even like the Word 2007 inbuilt picture editor. Your blogging tool ROCKS and I can use no other, I have tried all but hated all too.

KorenWolf
Posts: 1
Joined: 10.06.2007 16:38

Postby KorenWolf » 10.06.2007 18:01

I too love Blogdesk and had the same problem mentioned above.

I think Vista security is a little over cautious and you need to make yourself familiar with it in the early days of using it.

The simplest fix to the above problem is to go into Blogdesks program properties, go into compatibility and click on "Run this program as administrator". If you do this you don't need to do the other stuff mentioned above.

Happy BlogDesking everyone :-)

wullar
Posts: 4
Joined: 03.06.2007 08:00

Postby wullar » 10.06.2007 20:48

WOW! Thanks! It worked like a charm.

You rock!

(going to blog now!)


Return to “Bugs & Problems”